Développeurs: votre nouvelle application sur le Play Store doit cibler le niveau d'API 26

Lorsque Google a mis le système d'exploitation Android sur le marché pour la première fois, la société avait une approche de laisser-faire envers les développeurs. Après tout, la société devait inciter les développeurs à intégrer leurs applications et leurs services sur la nouvelle plateforme. Cependant, bon nombre de ces décisions précoces ont été reprises plus tard, car elles ont entraîné une expérience utilisateur médiocre - en permettant aux applications de faire ce qu'elles voulaient, les applications faisant ce qu'elles voulaient. Avec les nouvelles versions d'Android, les applications ne peuvent pas envoyer de notifications par courrier indésirable, utiliser des services d'arrière-plan sans avertir explicitement l'utilisateur, accéder à des autorisations sensibles sans qu'un dialogue ne leur octroie une autorisation, et bien plus encore. Pourtant, Google a facilité la tâche des applications pour contourner ces restrictions conviviales en leur permettant de continuer à cibler les anciennes versions du SDK. En décembre dernier, Google avait annoncé que toutes les nouvelles applications soumises au Google Play Store devaient cibler au moins le niveau API 26 (Android 8.0 Oreo). C'est finalement le mois d'août, ce qui signifie que si vous travaillez sur une nouvelle application et que vous envisagez de la soumettre au Play Store, il est préférable de cibler Android 8.0 Oreo!

Août 2018 - Toutes les nouvelles applications doivent cibler le niveau 26 de l'API

Google vous a laissé suffisamment de temps pour adapter votre application aux nouvelles exigences. Amener votre application à un niveau d'API plus récent sera bénéfique pour vous-même, ainsi que pour vos utilisateurs. Vos utilisateurs apprécieront le fait que votre application se comporte de manière cohérente avec les autres applications de leur appareil, alors que vous éviterez des maux de tête, car l'année prochaine, Google augmentera l'exigence targetSdkVersion. Si vous attendez et attendez de mettre à jour votre application pour répondre à cette exigence, sachez qu'après un an à compter de la sortie d'Android P, la nouvelle exigence de targetSdkVersion sera le niveau 28 ou supérieur de l'API.

Google n'essaie pas de vous punir en vous forçant à faire des efforts pour maintenir votre application à jour. La société souhaite simplement que vous aidiez à sécuriser les appareils de vos utilisateurs en veillant à utiliser toutes les dernières API et demandes de permission. Si vous craignez que les utilisateurs d'anciens appareils ne puissent pas utiliser votre application, sachez qu'il n'y a pas de plancher pour la version minimale du SDK que vous pouvez définir. En ce qui concerne les développeurs qui gèrent déjà une ou plusieurs applications sur le Play Store, votre application doit cibler le niveau 26 de l'API avant novembre 2018 si vous souhaitez être autorisé à soumettre des mises à jour de votre application sur le Play Store.